Portal Maintenance
Incident Report for spotlight Studios
Resolved
Maintenance Completed - Portal Live
Posted Jun 23, 2022 - 09:28 UTC
Update
Maintenance Completed
Posted Jun 23, 2022 - 09:27 UTC
Investigating
We're currently performing maintenance on our customer portal. We expect this to be concluded by ~13:00 23/06/2022
Posted Jun 23, 2022 - 08:51 UTC
This incident affected: Spotlight Studios (Customer Portal).